Tomcat 8 Java 8

Posted onby admin
TomcatTomcatTomcat 8 Java 8

This topic contains 6 replies, has 2 voices, and was last updated by 5 years, 7 months ago.

Tomcat 8.5 with java 8 running on 64bit amazon linux/3.3.2

Java 8 is supported on Jaspersoft 6.1 and above. As I was running on a time limit, I went ahead and installed it on a Java 7/Tomcat 7 system. I'll keep this in mind and see if I can upgrade everything down the line. Joined: Sep 21 2015 - 9:29pm. Last seen: 4 years 3 months ago.

Download Tomcat 8 For Windows

Tomcat 8.5 with java 8

Tomcat 8 Download

  • Michael,

    Could you be more specific about what is actually not working?

    I’ve seen a rather odd issue with Ubuntu 14.04, with either Java 7 or Java 8, and Tomcat 8. It looks like the second change, in any sequence of changes, isn’t being hot reloaded, at least not until a subsequent change is made. Is this what you’re seeing? It doesn’t happen on Windows.

    Michael,

    Are you using Open JDK to run Webclipse, by any chance? If so, it looks like that may cause some issues. If possible, please install an Oracle JDK (if you haven’t already installed it) and add the following 2 lines to the eclipse.ini file, before the -vmargs line:

    Please let us know if that helps.

    Michael,

    Thanks for letting us know. Yes, not having that option set would probably have an effect!

    I’ll let the developers know about this to see if they can modify the code to help in this situation.

  • Posts

Tomcat 8 Java 8 Docker Image

  • Is tomcat 8 (today as RC1 - see this) supporting Java 8, even if it is still in beta? Among others Tomcat 8 supports Java EE 7: Websockets; Servlet api 3.1 (Asynch servlet support) I had trouble in the past with Tomcat 7 / Java 7, that's why I am asking this question.
  • Note that I will definitely assume that we are going to deploy on Tomcat 8 as the title suggests, otherwise we will just run into troubles. Example for using CDI 1.2, we require at least EL 3.0, which is available only in Tomcat 8, not Tomcat 7.